Service Disruption

Incident Report for Honestly

Resolved

This incident has been resolved.
Posted May 06, 2026 - 00:41 CEST

Investigating

We are currently experiencing a service disruption.

Our Infrastructure team is working to identify the root cause
Posted May 05, 2026 - 23:51 CEST
This incident affected: Webapp.